One backup server is offline

June 06, Mon
Affected Service: Incremental Backup Service
  • Investigating
    One of our backup server is offline. We are currently investigating the issue and will continue to update you when we have more information.

    11:55, Jun 03 HKT
  • Resolved
    The affected backup server is back online.

    14:11, Jun 06 HKT
Back to current status