Web Hosting is Down

September 27, Tue
Affected Service: Web Hosting Service Cyberport HK
  • Investigating
    Some websites under your web hosting service is down, we are currently investigating the issues.

    17:03, Sep 27 HKT
  • Monitoring
    Most of your websites are back online, we will keep monitoring this issue.

    17:16, Sep 27 HKT
  • Resolved
    This incident is resolved.

    17:39, Sep 27 HKT
Back to current status