Web Hosting is Down

August 12, Fri
Affected Service: Web Hosting Service Cyberport HK
  • Investigating
    Some websites under your web hosting service is down, we are currently investigating the issues.

    15:32, Aug 11 HKT
  • Fixing
    We have identified the issue and are fixing the problem.

    15:34, Aug 11 HKT
  • Resolved
    The issue is resolved, all websites are up.

    10:46, Aug 12 HKT
Back to current status